re = /(?=([b]*[a]){3})(?=([a]*[b]){3})[ab]+/m
str = 'abab
aabbb
aaabb
abbaba
aaaabbb
abbabababbababbababab
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end