$re = '/(?=([b]*[a]){3})(?=([a]*[b]){3})[ab]+/m';
$str = 'abab
aabbb
aaabb
abbaba
aaaabbb
abbabababbababbababab
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);