package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<h3>([^\n]*\n+)+<a([^\n]*\n+)+<\/h3>`)
var str = `<h3>
144.000 TL
<a class="emlak-endeksi-link trackClick trackId_emlak-endeksi-link" id="emlakEndeksiLink">
Emlak Endeksi</a>
</h3>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}