import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<h3>([^\\n]*\\n+)+<a([^\\n]*\\n+)+<\\/h3>";
final String string = "<h3>\n"
+ "144.000 TL\n"
+ "<a class=\"emlak-endeksi-link trackClick trackId_emlak-endeksi-link\" id=\"emlakEndeksiLink\">\n"
+ "Emlak Endeksi</a>\n"
+ "</h3>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}