// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<h3>([^\n]*\n+)+<a([^\n]*\n+)+<\/h3>").unwrap();
let string = "<h3>
144.000 TL
<a class=\"emlak-endeksi-link trackClick trackId_emlak-endeksi-link\" id=\"emlakEndeksiLink\">
Emlak Endeksi</a>
</h3>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}