import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(ACVC|ALHAND|ATI|AVC|CRMG|FEDUC|GERO|PALIM|PFP|CRMG|RPGH)-[0-9]{13}-[0-9]{3}\\.(AVAN|MCPR|MCSC|PUPO|PUPS|PUSO|PUSS|RCRD|RMBI)\\.[a-zA-Z0-9]{8}-[0-9a-zA-Z]{7}";
final String string = "CRMG-1933071636600-001.PUPS.0WZMWZi8-oiiT1TE\n"
+ "PALIM-1971123014100-001.RCRD.J25PL5DG-00KBY4G\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}