// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(ACVC|ALHAND|ATI|AVC|CRMG|FEDUC|GERO|PALIM|PFP|CRMG|RPGH)-[0-9]{13}-[0-9]{3}\.(AVAN|MCPR|MCSC|PUPO|PUPS|PUSO|PUSS|RCRD|RMBI)\.[a-zA-Z0-9]{8}-[0-9a-zA-Z]{7}").unwrap();
let string = "CRMG-1933071636600-001.PUPS.0WZMWZi8-oiiT1TE
PALIM-1971123014100-001.RCRD.J25PL5DG-00KBY4G
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}