$re = '/(ACVC|ALHAND|ATI|AVC|CRMG|FEDUC|GERO|PALIM|PFP|CRMG|RPGH)-[0-9]{13}-[0-9]{3}\.(AVAN|MCPR|MCSC|PUPO|PUPS|PUSO|PUSS|RCRD|RMBI)\.[a-zA-Z0-9]{8}-[0-9a-zA-Z]{7}/m';
$str = 'CRMG-1933071636600-001.PUPS.0WZMWZi8-oiiT1TE
PALIM-1971123014100-001.RCRD.J25PL5DG-00KBY4G
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);