# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(title=)"[^"]*" (.*)name="([^"]*)"/$1"$3" $2/gm;t' <<< "title=\"alpha\" lorem ipsum lorem ipsum name=\"beta\"
title=\"omega\" Morbi posuere metus purus name=\"delta\""