#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(title=)"[^"]*" (.*)name="([^"]*)""
Local $sString = "title="alpha" lorem ipsum lorem ipsum name="beta"" & @CRLF & _
"title="omega" Morbi posuere metus purus name="delta""
Local $sSubst = "$1"$3" $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)