# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?P<time>\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2},\d{0,3}) (?P<message>fail2ban.*(?P<gid>\[\d*\]: )(?P<level>[A-Z]{4,7}) .*)"
test_str = ("2020-05-11 06:25:02,732 fail2ban.server [879]: INFO rollover performed on /var/log/fail2ban.log\n"
"2020-05-08 01:34:33,079 fail2ban.filter [16566]: INFO [sshd] Found 1.1.1.1 - 2020-05-08 01:34:33\n"
"2020-05-09 04:02:31,316 fail2ban.actions [16566]: NOTICE [sshd] Ban 1.0.0.1\n"
"2020-05-23 00:09:06,355 fail2ban.server [9474]: INFO Reload jail GHOST\n"
"2020-05-23 00:09:06,355 fail2ban.filter [9474]: INFO Removed logfile: '/opt/logs/ghost/https___nonsense_fyi_production.log'\n"
"2020-05-23 00:09:07,902 fail2ban.actions [9474]: NOTICE [GHOST] Flush ticket(s) with iptables-multiport\n"
"2020-05-23 00:09:07,902 fail2ban.actions [9474]: NOTICE [GHOST] Flush ticket(s) with iptables-allports\n"
"2020-05-23 00:09:09,699 fail2ban.jail [9474]: INFO Jail 'GHOST' stopped\n"
"2020-05-23 00:09:09,701 fail2ban.jail [9474]: INFO Creating new jail 'GHOST'\n"
"2020-05-23 00:09:09,701 fail2ban.jail [9474]: INFO Jail 'GHOST' uses pyinotify {}\n"
"2020-05-23 00:09:09,706 fail2ban.jail [9474]: INFO Initiated 'pyinotify' backend\n"
"2020-05-23 00:09:09,709 fail2ban.filter [9474]: INFO Added logfile: '/opt/logs/ghost/https___nonsense_fyi_production.log' (pos = 14909, hash = 7091b34995f750999f6c605cd6250439a2e0cde7)\n"
"2020-05-23 00:09:09,710 fail2ban.filter [9474]: INFO encoding: UTF-8\n"
"2020-05-23 00:09:09,711 fail2ban.filter [9474]: INFO maxRetry: 5\n"
"2020-05-23 00:09:09,711 fail2ban.filter [9474]: INFO findtime: 300\n"
"2020-05-23 00:09:09,712 fail2ban.actions [9474]: INFO banTime: 2592000\n"
"2020-05-23 00:09:09,714 fail2ban.jail [9474]: INFO Jail 'GHOST' started\n"
"2020-05-23 00:09:09,714 fail2ban.server [9474]: INFO Reload finished.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.