$re = '/{(?:[A-Za-z_][A-Za-z_0-9]*|[+\-*/%<=>&|()0-9. ])*}/';
$str = '// \\%def{ Value3 , name.len + (i * Person.age) + ( }
// %if{ (name.len == 20) && (value == 20) }';
$subst = "hello";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;