package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^.()]+)(?:\(([^.()]+)\))?(?:\.(gt|ge|lt|le|eq|bt|in|ct|no)(.*))?`)
var str = `s_dsd.no342`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}