re = /([^.()]+)(?:\(([^.()]+)\))?(?:\.(gt|ge|lt|le|eq|bt|in|ct|no)(.*))?/
str = 's_dsd.no342'
# Print the match result
str.match(re) do |match|
puts match.to_s
end