package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?si)<a[^>]+href="(?P<href>[^>"]+)"`)
var str = `<a href="http://google.com">hello</a>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}