const regex = new RegExp('(?si)<a[^>]+href="(?P<href>[^>"]+)"', '')
const str = `<a href="http://google.com">hello</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}