#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "test(?:(?!test)[^])*?XX12QW[^]*?(?=\s*test)"
Local $sString = "test " & @CRLF & _
"abc def " & @CRLF & _
"test 123 " & @CRLF & _
"test pqr " & @CRLF & _
"XX12QW" & @CRLF & _
"jkl XX12QW hjas " & @CRLF & _
"12asd23 test bxs"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")