using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"test(?:(?!test)[^])*?XX12QW[^]*?(?=\s*test)";
string input = @"test
abc def
test 123
test pqr
XX12QW
jkl XX12QW hjas
12asd23 test bxs";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}