use strict;
my $str = 'test
abc def
test 123
test pqr
XX12QW
jkl XX12QW hjas
12asd23 test bxs';
my $regex = qr/test(?:(?!test)[^])*?XX12QW[^]*?(?=\s*test)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}