re = /([\s\S]{2})/m
str = 'ABCDEF
GHIJK
LMNOP
QRSTU
VWXYZ
'
subst = '$1bbb'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result