$re = '/^([^-]*-[^-]*).*/m';
$str = 'aa-bbb-cccc
aa-vvv-vv
aa-ddd';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;