import re
regex = re.compile(r"^([^-]*-[^-]*).*", flags=re.MULTILINE)
test_str = ("aa-bbb-cccc\n"
"aa-vvv-vv\n"
"aa-ddd")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)