re = /^([^-]*-[^-]*).*/m
str = 'aa-bbb-cccc
aa-vvv-vv
aa-ddd'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result