#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*\[mmm\])(?=.*?\[a\.a\.a\.a\]).+(*SKIP)(*F)|.+"
Local $sString = "[Time] [mmm] [DATA] [rule] [a.a.a.a]" & @CRLF & _
"" & @CRLF & _
"[Time] [ppp] [DATA] [rule] [a.a.a.a]" & @CRLF & _
"" & @CRLF & _
"[Time] [mmm] [DATA] [rule] [c.c.c.c]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")