import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*\\[mmm\\])(?=.*?\\[a\\.a\\.a\\.a\\]).+(*SKIP)(*F)|.+";
final String string = "[Time] [mmm] [DATA] [rule] [a.a.a.a]\n\n"
+ "[Time] [ppp] [DATA] [rule] [a.a.a.a]\n\n"
+ "[Time] [mmm] [DATA] [rule] [c.c.c.c]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}