import re
regex = re.compile(r"^(?=.*\[mmm\])(?=.*?\[a\.a\.a\.a\]).+(*SKIP)(*F)|.+", flags=re.MULTILINE)
test_str = ("[Time] [mmm] [DATA] [rule] [a.a.a.a]\n\n"
"[Time] [ppp] [DATA] [rule] [a.a.a.a]\n\n"
"[Time] [mmm] [DATA] [rule] [c.c.c.c]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")