import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)\\biPhone:\\n\\n+(?:(?!\\n\\n).)+\\bSerial Number: (\\w+)";
final String string = "USB:\n\n"
+ "USB 2.0 SuperSpeed Bus:\n\n"
+ " Host Controller Location: Built-in USB\n\n"
+ " Internal Memory Card Reader:\n\n"
+ " Product ID: 0x8406\n"
+ " Serial Number: 000000000820 //i dont want this\n"
+ " Built-In: Yes\n\n"
+ "USB 3.0 Hi-Speed Bus:\n\n"
+ " PCI Device ID: 0x8c31 \n\n\n"
+ " iPhone:\n\n"
+ " Vendor ID: 0x05ac (Apple Inc.)\n"
+ " Version: 7.02\n"
+ " Serial Number: wea0aa752ada7722ac92575e98z2e89c691f4282 //i want this\n"
+ " Speed: Up to 480 Mb/sec\n"
+ " Manufacturer: Apple Inc.\n"
+ " Location ID: 0x14100000 / 9\n\n"
+ " Apple Internal Keyboard / Trackpad:\n\n"
+ " Product ID: 0x0262\n"
+ " Vendor ID: 0x05ac (Apple Inc.)\n"
+ " Location ID: 0x14c00000 / 3\n"
+ " Current Available (mA): 500\n"
+ " Current Required (mA): 40\n"
+ " Built-In: Yes";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}