re = /(?s)\biPhone:\n\n+(?:(?!\n\n).)+\bSerial Number: (\w+)/m
str = 'USB:
USB 2.0 SuperSpeed Bus:
Host Controller Location: Built-in USB
Internal Memory Card Reader:
Product ID: 0x8406
Serial Number: 000000000820 //i dont want this
Built-In: Yes
USB 3.0 Hi-Speed Bus:
PCI Device ID: 0x8c31
iPhone:
Vendor ID: 0x05ac (Apple Inc.)
Version: 7.02
Serial Number: wea0aa752ada7722ac92575e98z2e89c691f4282 //i want this
Speed: Up to 480 Mb/sec
Manufacturer: Apple Inc.
Location ID: 0x14100000 / 9
Apple Internal Keyboard / Trackpad:
Product ID: 0x0262
Vendor ID: 0x05ac (Apple Inc.)
Location ID: 0x14c00000 / 3
Current Available (mA): 500
Current Required (mA): 40
Built-In: Yes'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end