import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*;\\[\\w\\w\\].*).*";
final String string = "Sendinput, {f1}+{Insert}\n"
+ "Sendinput, {f1}+{Pause}\n"
+ "Sendinput, {f1}+{Home}\n"
+ "Sendinput, {f1}+{PgUp}\n"
+ "Sendinput, {f1}+{PgDn}\n\n"
+ "Sendinput, {f2}{a} ;[2r] [3D Model Tre]\n"
+ "Sendinput, {f2}{b} ;[3b] [Accessibility Checker ]\n"
+ "Sendinput, {f2}{c} ;[2z] [Accessibility Report r]\n"
+ "Sendinput, {f2}{d} ;[5r] [Attachments]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}