import Foundation
let pattern = #"^(?!.*;\[\w\w\].*).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Sendinput, {f1}+{Insert}
Sendinput, {f1}+{Pause}
Sendinput, {f1}+{Home}
Sendinput, {f1}+{PgUp}
Sendinput, {f1}+{PgDn}
Sendinput, {f2}{a} ;[2r] [3D Model Tre]
Sendinput, {f2}{b} ;[3b] [Accessibility Checker ]
Sendinput, {f2}{c} ;[2z] [Accessibility Report r]
Sendinput, {f2}{d} ;[5r] [Attachments]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)