# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!.*;\[\w\w\].*).*"
test_str = ("Sendinput, {f1}+{Insert}\n"
"Sendinput, {f1}+{Pause}\n"
"Sendinput, {f1}+{Home}\n"
"Sendinput, {f1}+{PgUp}\n"
"Sendinput, {f1}+{PgDn}\n\n"
"Sendinput, {f2}{a} ;[2r] [3D Model Tre]\n"
"Sendinput, {f2}{b} ;[3b] [Accessibility Checker ]\n"
"Sendinput, {f2}{c} ;[2z] [Accessibility Report r]\n"
"Sendinput, {f2}{d} ;[5r] [Attachments]")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.