re = /(\d{1,3})(\d{4})/
str = ' 1710ABCD.131711ABCD.431711ABCD.41711ABCD.4041711ABCD.25'
subst = '\\1,\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result