import Foundation
let pattern = #"(\d{1,3})(\d{4})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #" 1710ABCD.131711ABCD.431711ABCD.41711ABCD.4041711ABCD.25"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1,\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)