using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^(?:a|c|bc)+$)";
string input = @"abc
acb
ccbc
bac
bca
aaa
cab
cba
cabcabcbacbcaaaccbbaaccacbac";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}