using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<link>{link name=(\""|")(?<name>(?:(?!\2).)*)\2 url=(\""|")(?<url>(?:(?!\4).)*)\4})";
string input = @"{link name=""Link 2"" url=""http://www.google.com""}
{link name="Link 2" url="http://www.google.com"}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}