import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<link>\\{link name=(\\\"|")(?<name>(?:(?!\\2).)*)\\2 url=(\\\"|")(?<url>(?:(?!\\4).)*)\\4\\})";
final String string = "{link name=\"Link 2\" url=\"http://www.google.com\"}\n\n"
+ "{link name="Link 2" url="http://www.google.com"}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}