$re = '/(?<link>{link name=(\"|")(?<name>(?:(?!\2).)*)\2 url=(\"|")(?<url>(?:(?!\4).)*)\4})/';
$str = '{link name="Link 2" url="http://www.google.com"}
{link name="Link 2" url="http://www.google.com"}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);