using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-z0-9][a-z0-9-.]{0,32}[a-z0-9])(\@[a-z0-9][a-z0-9-]{0,32}[a-z0-9])((?:\.[a-z]{2,5}){1,2})$";
string input = @"gustavo.americo@live.com";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}