// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^([a-z0-9][a-z0-9-.]{0,32}[a-z0-9])(\@[a-z0-9][a-z0-9-]{0,32}[a-z0-9])((?:\.[a-z]{2,5}){1,2})$").unwrap();
let string = "gustavo.americo@live.com";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}