package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([a-z0-9][a-z0-9-.]{0,32}[a-z0-9])(\@[a-z0-9][a-z0-9-]{0,32}[a-z0-9])((?:\.[a-z]{2,5}){1,2})$`)
var str = `gustavo.americo@live.com`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}