package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*\+.*$`)
var str = `applesx4
bagofflour
bagofsugar
milkx2
appple+20gfree
BELIHGMSWATALA+VATT100gBARWR
TOOLAITCASSE+LSST+SSSRE40gSACMDC
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}