re = /^.*\+.*$/m
str = 'applesx4
bagofflour
bagofsugar
milkx2
appple+20gfree
BELIHGMSWATALA+VATT100gBARWR
TOOLAITCASSE+LSST+SSSRE40gSACMDC
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end