$re = '/^.*\+.*$/m';
$str = 'applesx4
bagofflour
bagofsugar
milkx2
appple+20gfree
BELIHGMSWATALA+VATT100gBARWR
TOOLAITCASSE+LSST+SSSRE40gSACMDC
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);