using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([А-ЯЁа-яё]+,\s[А-ЯЁа-яё]{1}\.\s[А-ЯЁа-яё]{1}\.\s)+.+";
string input = @"Череухин, В. А. Карпов, А. В. Анализ";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}