$re = '/([А-ЯЁа-яё]+,\s[А-ЯЁа-яё]{1}\.\s[А-ЯЁа-яё]{1}\.\s)+.+/';
$str = 'Череухин, В. А. Карпов, А. В. Анализ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);