re = /([А-ЯЁа-яё]+,\s[А-ЯЁа-яё]{1}\.\s[А-ЯЁа-яё]{1}\.\s)+.+/
str = 'Череухин, В. А. Карпов, А. В. Анализ'
# Print the match result
str.match(re) do |match|
puts match.to_s
end