use strict;
my $str = '01:58:29
12:05:19
13:59:03
00:00:00
23:59:59
00:59:59
00:00:59
23:00:00
24:00:00
00:60:00
00:00:60';
my $regex = qr/^(?:(?:[0-1][0-9])|2[0-3]):[0-5][0-9]:[0-5][0-9]$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}