re = /^(?:(?:[0-1][0-9])|2[0-3]):[0-5][0-9]:[0-5][0-9]$/mi
str = '01:58:29
12:05:19
13:59:03
00:00:00
23:59:59
00:59:59
00:00:59
23:00:00
24:00:00
00:60:00
00:00:60'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end