// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(?:(?:[0-1][0-9])|2[0-3]):[0-5][0-9]:[0-5][0-9]$").unwrap();
let string = "01:58:29
12:05:19
13:59:03
00:00:00
23:59:59
00:59:59
00:00:59
23:00:00
24:00:00
00:60:00
00:00:60";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}