$re = '/^[a-zA-Z][a-zA-Z0-9_]{0,29}(?:\.[a-zA-Z][a-zA-Z0-9_]{0,29})?$/';
$str = 'abcghi_klxyz_BCDj.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);